跳轉到主要內容

ambari 2.7.6+hdp 3.1.5安裝kafka 3.0.0版本

分類
故障描述

  無

故障分析

  無

處理過程

hdp 3.1.5默認集成kafka2,客戶需要安裝kafka3

安裝如下:

cd /opt
wget http://vpn.coremtech.com:20080/kafka3/kafka_2.12-3.0.0.tgz
wget http://vpn.coremtech.com:20080/kafka3/server.properties
wget http://vpn.coremtech.com:20080/kafka3/start.txt
tar zxvf kafka_2.12-3.0.0.tgz
cp server.properties kafka_2.12-3.0.0/config/
vi kafka_2.12-3.0.0/config/server.properties
# change id
mkdir /data-a/kafka3-logs
/opt/kafka_2.12-3.0.0/bin/kafka-server-start.sh ?-daemon /opt/kafka_2.12-3.0.0/config/server.properties

?

建議/總結

  一個zk環境,支持兩個不同kafka版本,僅需要zk連接器后加新的命名即可。例如master:2181/kafka3

黄色app-黄软件下载-黄软件破解版免费版_黄软件破解版下载大全